Thread (45 messages) 45 messages, 6 authors, 2025-03-08

Re: [PATCH 2/3] dt-bindings: net: Document GBETH bindings for Renesas RZ/V2H(P) SoC

flat view

From: Andrew Lunn <andrew@lunn.ch>
Date: 2025-03-02 21:34:14
Also in: linux-devicetree, linux-renesas-soc, lkml

On Sun, Mar 02, 2025 at 07:28:09PM +0000, Russell King (Oracle) wrote:
On Sun, Mar 02, 2025 at 08:10:26PM +0100, Andrew Lunn wrote:
quoted
quoted
+  interrupts:
+    items:
+      - description: Subsystem interrupt
+      - description: The interrupt to manage the remote wake-up packet detection
+      - description: The interrupt that occurs when Tx/Rx enters/exits the LPI state
+      - description: Per-channel transmission-0 completion interrupt
+      - description: Per-channel transmission-1 completion interrupt
+      - description: Per-channel transmission-2 completion interrupt
+      - description: Per-channel transmission-3 completion interrupt
+      - description: Per-channel receive-0 completion interrupt
+      - description: Per-channel receive-1 completion interrupt
+      - description: Per-channel receive-2 completion interrupt
+      - description: Per-channel receive-3 completion interrupt
+
+  interrupt-names:
+    items:
+      - const: macirq
+      - const: eth_wake_irq
+      - const: eth_lpi
+      - const: tx0
+      - const: tx1
+      - const: tx2
+      - const: tx3
+      - const: rx0
+      - const: rx1
+      - const: rx2
+      - const: rx3
There has already been a discussion about trying to make the clock
names more uniform. But what about interrupts? Which of these are in
the IP databook? What names does the databook use for these
interrupts?
quoted
From a quick look, I haven't found anything that suggests the above
is possible, but it clearly is... so I'll look more tomorrow.
stmmac_platform.c:	stmmac_res->irq = platform_get_irq_byname(pdev, "macirq");
stmmac_platform.c:		platform_get_irq_byname_optional(pdev, "eth_wake_irq");
stmmac_platform.c:		platform_get_irq_byname_optional(pdev, "eth_lpi");
stmmac_platform.c:		platform_get_irq_byname_optional(pdev, "sfty");

So it looks like these are already in common code. So there should be
no need to name them in individual bindings, they can be named in the
common binding, and the vendor binding then just needs to indicate
they are required, or not.

What i have not yet figure out is how the names tx0, .. tx3 in this
binding are used. There is no code added in this patchset. Yet
loongson_dwmac_msi_config() and the intel stmmac_config_multi_msi()
are the only ones setting res->tx_irq[], neither of which are using
DT? I must be missing something somewhere.

    Andrew

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help