Thread (27 messages) flat view 27 messages, 5 authors, 2012-08-01

RE: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code

From: Jia Hongtao-B38951 <hidden>
Date: 2012-07-31 06:36:58

-----Original Message-----
From: Kumar Gala [mailto:galak@kernel.crashing.org]
Sent: Monday, July 30, 2012 10:47 PM
To: Jia Hongtao-B38951
Cc: Wood Scott-B07421; linuxppc-dev@lists.ozlabs.org; Li Yang-R58472
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
initialization code
=20
=20
On Jul 30, 2012, at 3:26 AM, Jia Hongtao-B38951 wrote:
=20
quoted
quoted
-----Original Message-----
From: Kumar Gala [mailto:galak@kernel.crashing.org]
Sent: Saturday, July 28, 2012 5:17 AM
To: Wood Scott-B07421
Cc: Jia Hongtao-B38951; linuxppc-dev@lists.ozlabs.org; Wood Scott-
B07421;
quoted
quoted
Li Yang-R58472
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
initialization code


On Jul 27, 2012, at 3:24 PM, Scott Wood wrote:
quoted
On 07/27/2012 05:10 AM, Jia Hongtao-B38951 wrote:
quoted
Hi kumar,

I know "duplicate code from pci_process_bridge_OF_ranges()" is
hard to accept but "refactor the code to have a shared function"
is knotty. Actually this is the reason I didn't do the refactor.
Maybe we should keep doing the init early?  We could still have a
platform device for the PM stuff, but some init would be done before
probe.
quoted
Another possibility is to try to handle swiotlb init later --
possibly
quoted
quoted
quoted
by reserving memory for it if the platform indicates it's a
possibility
quoted
quoted
quoted
that it will be needed, then freeing the memory if it's not needed.

-Scott
I think the first option seems reasonable.  Can we leave fsl_pci_init(=
)
quoted
quoted
as we now have it and just have the platform driver deal with PM
restore
quoted
quoted
via calling setup_pci_atmu() [probably need to update setup_pci_atmu
to
quoted
quoted
handle restore case, but seems like minor changes]

- k

I think the second option is better if it's hard to decouple swiotlb
determination from pci init. I believe the better architecture that
PCI init in probe function of platform driver will bring us
considerable
quoted
advantage. I really like to keep the completion of pci controller
platform driver not only for PM support but also for pci init.

-Hongtao.
=20
Shifting of swiotlb init has a lot more issues.  Why do we need to do the
PCI init in probe?
=20
- k
I investigated the swiotlb init thing and found that in x86 swiotlb init is
done first and free if we don't need it.

-Hongtao.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help