Thread (27 messages) flat view 27 messages, 5 authors, 2012-08-01

RE: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code

From: Jia Hongtao-B38951 <hidden>
Date: 2012-07-27 08:35:52

-----Original Message-----
From: Kumar Gala [mailto:galak@kernel.crashing.org]
Sent: Friday, July 27, 2012 2:15 AM
To: Jia Hongtao-B38951
Cc: linuxppc-dev@lists.ozlabs.org; Wood Scott-B07421; Li Yang-R58472
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
initialization code
=20
=20
On Jul 26, 2012, at 7:30 AM, Jia Hongtao wrote:
=20
quoted
We unified the Freescale pci/pcie initialization by changing the
fsl_pci
quoted
to a platform driver. In previous PCI code architecture the
initialization
quoted
routine is called at board_setup_arch stage. Now the initialization is
done
quoted
in probe function which is architectural better. Also It's convenient
for
quoted
adding PM support for PCI controller in later patch.

One issue introduced by this architecture is the timing of swiotlb_init=
.
quoted
During PCI initialization the need of swiotlb is determined and this
should
quoted
be done before swiotlb_init. So a new function to determine swiotlb by
parsing pci ranges is made. This function is called at board_setup_arch
stage which is earlier than swiotlb_init.

Signed-off-by: Jia Hongtao <redacted>
Signed-off-by: Li Yang <redacted>
---
Changed for V3:
- Rebase the patch set on the latest tree
- merge PCI unify and swiotlb patch into one

arch/powerpc/sysdev/fsl_pci.c |  155 ++++++++++++++++++++++++++++++++--
-------
quoted
arch/powerpc/sysdev/fsl_pci.h |    9 +--
2 files changed, 125 insertions(+), 39 deletions(-)
=20
I'd like the SWIOTLB refactoring as a separate patch.  Additionally, the
order of patches should be as follows:
=20
1. refactor PCI node parsing code
2. add pci_determine_swiotlb (should rename to fsl_pci_determine_swiotlb)
3. Determine primary bus by looking for ISA node
4. convert all boards over to fsl_pci_init
5. convert fsl pci to platform driver (edac and other fixes should be
merged in here)
6. PM support
=20
- k
Should I convert all boards over to fsl_pci_init first and then convert the=
m
over to platform driver again or just convert them direct to platform drive=
r?

Thanks.
-Hongtao.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help