Thread (27 messages) flat view 27 messages, 5 authors, 2012-08-01

Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code

From: Kumar Gala <hidden>
Date: 2012-07-30 14:46:54

On Jul 30, 2012, at 3:07 AM, Jia Hongtao-B38951 wrote:
quoted
-----Original Message-----
From: Kumar Gala [mailto:galak@kernel.crashing.org]
Sent: Friday, July 27, 2012 8:47 PM
To: Jia Hongtao-B38951
Cc: linuxppc-dev@lists.ozlabs.org; Wood Scott-B07421; Li Yang-R58472
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
initialization code
=20
=20
On Jul 27, 2012, at 3:35 AM, Jia Hongtao-B38951 wrote:
=20
quoted
=20
=20
quoted
-----Original Message-----
From: Kumar Gala [mailto:galak@kernel.crashing.org]
Sent: Friday, July 27, 2012 2:15 AM
To: Jia Hongtao-B38951
Cc: linuxppc-dev@lists.ozlabs.org; Wood Scott-B07421; Li =
Yang-R58472
quoted
quoted
quoted
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
initialization code
=20
=20
On Jul 26, 2012, at 7:30 AM, Jia Hongtao wrote:
=20
quoted
We unified the Freescale pci/pcie initialization by changing the
fsl_pci
quoted
to a platform driver. In previous PCI code architecture the
initialization
quoted
routine is called at board_setup_arch stage. Now the =
initialization
quoted
is
quoted
quoted
done
quoted
in probe function which is architectural better. Also It's =
convenient
quoted
quoted
quoted
for
quoted
adding PM support for PCI controller in later patch.
=20
One issue introduced by this architecture is the timing of
swiotlb_init.
quoted
quoted
quoted
During PCI initialization the need of swiotlb is determined and =
this
quoted
quoted
quoted
should
quoted
be done before swiotlb_init. So a new function to determine =
swiotlb
quoted
by
quoted
quoted
quoted
parsing pci ranges is made. This function is called at
board_setup_arch
quoted
quoted
quoted
stage which is earlier than swiotlb_init.
=20
Signed-off-by: Jia Hongtao <redacted>
Signed-off-by: Li Yang <redacted>
---
Changed for V3:
- Rebase the patch set on the latest tree
- merge PCI unify and swiotlb patch into one
=20
arch/powerpc/sysdev/fsl_pci.c |  155
++++++++++++++++++++++++++++++++--
quoted
quoted
-------
quoted
arch/powerpc/sysdev/fsl_pci.h |    9 +--
2 files changed, 125 insertions(+), 39 deletions(-)
=20
I'd like the SWIOTLB refactoring as a separate patch.  =
Additionally,
quoted
the
quoted
quoted
order of patches should be as follows:
=20
1. refactor PCI node parsing code
2. add pci_determine_swiotlb (should rename to
fsl_pci_determine_swiotlb)
quoted
quoted
3. Determine primary bus by looking for ISA node
4. convert all boards over to fsl_pci_init
5. convert fsl pci to platform driver (edac and other fixes should =
be
quoted
quoted
quoted
merged in here)
6. PM support
=20
- k
=20
Should I convert all boards over to fsl_pci_init first and then =
convert
quoted
them
quoted
over to platform driver again or just convert them direct to =
platform
quoted
driver?
=20
Yes do the fsl_pci_init conversion first.  The reason is we should =
NOT
quoted
break functionality from one patch to another.
=20
- k
=20
=20
Actually, the functionality is not broken, other boards just use the =
old
Way to init pci controller and it still works.
How do you figure?  The platform driver is going to get called on boards =
not yet converted.  So than you will get 2 different inits of PCI going =
on.

- k=
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help