Thread (27 messages) flat view 27 messages, 5 authors, 2012-08-01

Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code

From: Kumar Gala <hidden>
Date: 2012-07-27 21:17:30

On Jul 27, 2012, at 3:24 PM, Scott Wood wrote:
On 07/27/2012 05:10 AM, Jia Hongtao-B38951 wrote:
quoted
Hi kumar,
=20
I know "duplicate code from pci_process_bridge_OF_ranges()" is
hard to accept but "refactor the code to have a shared function"
is knotty. Actually this is the reason I didn't do the refactor.
=20
Maybe we should keep doing the init early?  We could still have a
platform device for the PM stuff, but some init would be done before =
probe.
=20
Another possibility is to try to handle swiotlb init later -- possibly
by reserving memory for it if the platform indicates it's a =
possibility
that it will be needed, then freeing the memory if it's not needed.
=20
-Scott
I think the first option seems reasonable.  Can we leave fsl_pci_init() =
as we now have it and just have the platform driver deal with PM restore =
via calling setup_pci_atmu() [probably need to update setup_pci_atmu to =
handle restore case, but seems like minor changes]

- k
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help