On Sun, May 09, 2010 at 12:53:17AM +0200, Eyvind Bernhardsen wrote:
On 9. mai 2010, at 00.17, Eyvind Bernhardsen
[off-list ref] wrote:
quoted
I'll try to think of a better name.
Heh. How about "localcrlf={true,false,native}"?
It breaks down a bit if we ever decide to support old-school-Mac-style
CR line endings, but at that point you're approaching the borders of
madness anyway.
It seems that autocrlf is currently so troublesome that most people end up
disabling it, and handling it in other ways (we certainly do).
Instead of keeping the names and trying to graft on something that is
almost backwards compatible, and forever live with names that we agree
are bad, what about:
Deprecate core.autocrlf and the crlf attribute.
Make these instead:
Configs:
core.eol = lf, crlf, native [default=native]
core.eolconversion = true, false, auto [default=unset]
Attribute:
eolconversion = true, false, auto [default=core.eolconversion]
- Finn Arne