On Sat, 8 May 2010, Eyvind Bernhardsen wrote:
Introduce a new configuration variable, "core.eolStyle", that allows the
user to set which line endings to use for end-of-line-normalized files
in the working directory. It defaults to "native", which means CRLF on
Windows and LF everywhere else.
So I at least agree with the semantics now, but I think that we really
would be better off just calling it "core.crlf". I don't _care_ whether
people think it's a bad name - much worse than a bad name is to use a name
that is not consistent.
Having two config variables named "core.autocrlf" and "core.crlf" at least
is consistent. Having "autocrlf" and "eolStyle" is just messed up.
Linus