On Sun, 9 May 2010, Eyvind Bernhardsen wrote:
Heh. How about "localcrlf={true,false,native}"?
I really don't understand that. What would it even mean?
An you _do_ realize that like it or not, we already have "crlf=input" as
the syntax in our .gitattributes files? So that exact syntax already
exists in one place.
As mentioned, I really can understand people not liking the name, but we
already _have_ that name, and that syntax. I think it makes more sense to
try to have a unified syntax than have two different strings for the same
thing.
So I think we'd be better off with good documentation with a couple of
real examples (and easily findable), so that the naming is at least
something people can look up and see the semantics for. The "eol" vs
"crlf" thing is just bike shedding, and we already ended up with "crlf".
In contrast, making docs understandable is more than bikeshedding.
Linus