quoted
quoted
quoted
quoted
"Grant" == Grant Likely [off-list ref] writes:
Hi,
Grant> +static int uartlite_open(void)
Grant> +{
Grant> + /* Clear the RX FIFO */
Grant> + out_be32(reg_base + 0x0C, 0x2);
Grant> + return 0;
Grant> +}
Grant> +
Grant> +static void uartlite_putc(unsigned char c)
Grant> +{
Grant> + while ((in_be32(reg_base + 0x8) & 0x08) != 0); /* spin */
Grant> + out_be32(reg_base + 0x4, c);
RX, TX, STATUS and CONTROL defines for the registers would be nice for
readability.
--
Bye, Peter Korsgaard