Re: [RFC] pinctrl: pinconf-generic: move ..dt_node_to_map_pinmux() to amlogic-am4 driver
From: Andy Shevchenko <hidden>
Date: 2026-02-04 16:17:04
Also in:
linux-amlogic, linux-gpio, lkml
On Wed, Feb 04, 2026 at 03:50:02PM +0000, Conor Dooley wrote:
On Wed, Feb 04, 2026 at 04:26:29PM +0200, Andy Shevchenko wrote:quoted
On Wed, Feb 04, 2026 at 04:22:47PM +0200, Andy Shevchenko wrote:quoted
On Wed, Feb 04, 2026 at 02:15:10PM +0000, Conor Dooley wrote:quoted
On Wed, Feb 04, 2026 at 09:05:34AM +0100, Andy Shevchenko wrote:quoted
On Wed, Feb 04, 2026 at 12:34:36AM +0100, Linus Walleij wrote:quoted
On Tue, Feb 3, 2026 at 5:17 PM Conor Dooley [off-list ref] wrote:
...
quoted
quoted
quoted
quoted
Note, please, remove extra '.' (dot) in the Subject.ofwiw, the .. was intentional cos I was truncating the pinconf_generic from the function since the subject was really long, not referring to a member of an ops struct.Yes, and that's how we refer to the callbacks — with a single dot and parentheses: .my_cool_cb() Alternatively ->my_cool_cb() but it one character longer and TBH it slightly less readable (I personally used the latter and then switched to the former in the recent years).Hmm... My memory tricked me, it seems I switched to ->cb() notation, at least there are patches with that from October last year. Whatever, choose one and use it :-)I think you missed my point, I was /not/ trying to refer to an ops struct member. For those I follow the first of the two notations you listed.
Indeed, for that cases I usually use and underscore (however it might in some cases be ambiguous): pinctrl: pinconf-generic: move _dt_node_to_map_pinmux() to amlogic-am4 driver I think it's possible to drop the 'pinctrl:' prefix, the pinconf-generic is unique enough and had been used in the past a couple of times (yes, I know that the convention is to use subsystem prefix). Also word 'driver' can be dropped. TL;DR: My point that double dots is confusing and non-standard way to refer to something which is cut. If not full, ideally it can use triple dots followed by underscore pinconf-generic: move ..._dt_node_to_map_pinmux() to amlogic-am4 driver -- With Best Regards, Andy Shevchenko