Thread (10 messages) 10 messages, 3 authors, 2026-02-06

Re: [RFC] pinctrl: pinconf-generic: move ..dt_node_to_map_pinmux() to amlogic-am4 driver

From: Andy Shevchenko <hidden>
Date: 2026-02-04 14:26:34
Also in: linux-amlogic, linux-gpio, lkml

On Wed, Feb 04, 2026 at 04:22:47PM +0200, Andy Shevchenko wrote:
On Wed, Feb 04, 2026 at 02:15:10PM +0000, Conor Dooley wrote:
quoted
On Wed, Feb 04, 2026 at 09:05:34AM +0100, Andy Shevchenko wrote:
quoted
On Wed, Feb 04, 2026 at 12:34:36AM +0100, Linus Walleij wrote:
quoted
On Tue, Feb 3, 2026 at 5:17 PM Conor Dooley [off-list ref] wrote:
...
quoted
quoted
Note, please, remove extra '.' (dot) in the Subject.o
fwiw, the .. was intentional cos I was truncating the pinconf_generic
from the function since the subject was really long, not referring to
a member of an ops struct.
Yes, and that's how we refer to the callbacks — with a single dot and parentheses:

	.my_cool_cb()

Alternatively

	->my_cool_cb()

but it one character longer and TBH it slightly less readable (I personally
used the latter and then switched to the former in the recent years).
Hmm... My memory tricked me, it seems I switched to ->cb() notation, at least
there are patches with that from October last year. Whatever, choose one and
use it :-)

-- 
With Best Regards,
Andy Shevchenko


Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help