Thread (84 messages) flat view 84 messages, 6 authors, 2019-03-19

Re: [PATCH v7 01/15] sched/core: uclamp: Add CPU's clamp buckets refcounting

From: Suren Baghdasaryan <surenb@google.com>
Date: 2019-03-13 21:08:37
Also in: linux-pm, lkml

On Wed, Mar 13, 2019 at 12:46 PM Peter Zijlstra [off-list ref] wrote:
On Wed, Mar 13, 2019 at 03:23:59PM +0000, Patrick Bellasi wrote:
quoted
On 13-Mar 15:09, Peter Zijlstra wrote:
quoted
On Fri, Feb 08, 2019 at 10:05:40AM +0000, Patrick Bellasi wrote:
quoted
quoted
quoted
+static inline void uclamp_rq_update(struct rq *rq, unsigned int clamp_id)
+{
+ struct uclamp_bucket *bucket = rq->uclamp[clamp_id].bucket;
+ unsigned int max_value = uclamp_none(clamp_id);
That's 1024 for uclamp_max
quoted
+ unsigned int bucket_id;
+
+ /*
+  * Both min and max clamps are MAX aggregated, thus the topmost
+  * bucket with some tasks defines the rq's clamp value.
+  */
+ bucket_id = UCLAMP_BUCKETS;
+ do {
+         --bucket_id;
+         if (!rq->uclamp[clamp_id].bucket[bucket_id].tasks)
+                 continue;
+         max_value = bucket[bucket_id].value;
but this will then _lower_ it. That's not a MAX aggregate.
For uclamp_max we want max_value=1024 when there are no active tasks,
which means: no max clamp enforced on CFS/RT "idle" cpus.

If instead there are active RT/CFS tasks then we want the clamp value
of the max group, which means: MAX aggregate active clamps.

That's what the code above does and the comment says.
That's (obviously) not how I read it... maybe something like:

static inline void uclamp_rq_update(struct rq *rq, unsigned int clamp_id)
{
        struct uclamp_bucket *bucket = rq->uclamp[clamp_id].bucket;
        int i;

        /*
         * Since both min and max clamps are max aggregated, find the
         * top most bucket with tasks in.
         */
        for (i = UCLMAP_BUCKETS-1; i>=0; i--) {
                if (!bucket[i].tasks)
                        continue;
                return bucket[i].value;
        }

        /* No tasks -- default clamp values */
        return uclamp_none(clamp_id);
}

would make it clearer?
This way it's also more readable/obvious when it's used inside
uclamp_rq_dec_id, assuming uclamp_rq_update is renamed into smth like
get_max_rq_uclamp.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help