Thread (218 messages) flat view 218 messages, 9 authors, 2016-11-06

Re: [PATCH 08/22] sequencer: remove overzealous assumption

From: Jakub Narębski <hidden>
Date: 2016-08-31 18:47:20

Hello Johannes,

W dniu 31.08.2016 o 20:36, Johannes Schindelin pisze:
On Wed, 31 Aug 2016, Jakub Narębski wrote: 
quoted
W dniu 29.08.2016 o 10:04, Johannes Schindelin pisze:
 
I am of the opinion that overzealous checking of certain implementation
details is something to be avoided.
I agree.
quoted
quoted
Therefore let's just get rid of the test that wants to verify that this
limitation is still in place, in preparation for the upcoming work to
teach the sequencer to do rebase -i's work.
Is it "upcoming work" as in one of the patches in this series?
If so, which patch?
I left this a little vague, didn't I? ;-)

The problem is that the `git-rebase-todo` most definitely does *not* want
to be restricted to a single command.

So if you must have a patch that disagrees with this overzealous check,
the "revamp todo parsing" one is probably the first. But it is better to
think of this at a higher level than just patches: it is wrong to limit
the todo script to contain only identical commands.
I see.  Right.

I wonder: would 'git cherry-pick --continue' be able to finish
'git revert', and vice versa, then?  Or 'git sequencer --continue'?
quoted
quoted
diff --git a/t/t3510-cherry-pick-sequence.sh b/t/t3510-cherry-pick-sequence.sh
index 7b7a89d..6465edf 100755
--- a/t/t3510-cherry-pick-sequence.sh
+++ b/t/t3510-cherry-pick-sequence.sh
@@ -459,17 +459,6 @@ test_expect_success 'malformed instruction sheet 1' '
 	test_expect_code 128 git cherry-pick --continue
 '
 
-test_expect_success 'malformed instruction sheet 2' '
Hmmm... the description is somewhat lacking (especially compared to
the rest of test), anyway.

BTW. we should probably rename 'malformed instruction sheet 2'
to 'malformed instruction sheet' if there are no further such
tests after this removal, isn't it?
No, we cannot rename it after this patch because the patch removes it ;-)
(It is not a file name but really a label for a test case.)
Ooops.  What I wanted to say that after removing the test case named
'malformed instruction sheet 2' we should also rename *earlier* test
case from 'malformed instruction sheet 1' to 'malformed instruction sheet',
as it is now the only 'malformed instruction sheet *' test case.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help