Thread (218 messages) flat view 218 messages, 9 authors, 2016-11-06

Re: [PATCH 05/22] sequencer: allow the sequencer to take custody of malloc()ed data

From: Johannes Schindelin <hidden>
Date: 2016-08-30 07:31:09

Hi Hannes,

On Tue, 30 Aug 2016, Johannes Sixt wrote:
Am 29.08.2016 um 23:59 schrieb Jakub Narębski:
quoted
W dniu 29.08.2016 o 10:04, Johannes Schindelin pisze:
quoted
-#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL,
NULL, NULL, 0, 0, NULL }
+#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL,
NULL, NULL, 0, 0, NULL, NULL, 0, 0 }
Nb. it is a pity that we cannot use named initializers for structs,
so called designated inits.  It would make this macro more readable.
It is actually pointless to add the 0's and NULL's here. This should  be
sufficient:

#define REPLAY_OPTS_INIT { -1, -1 }

because initialization with 0 (or NULL) is the default for any omitted
members.
D'oh. You're right. The same applies to TODO_LIST_INIT, of course.

Fixed,
Johannes
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help