Re: [PATCH 12/21] Use prefixcmp() instead of memcmp() for cleaner code with less magic numbers
From: Alex Riesen <hidden> Date: 2016-06-15 22:43:15
On 6/9/07, Johan Herland [off-list ref] wrote:
+/*
+ * Perform parsing and verification of tag object data.
+ *
+ * The 'item' parameter may be set to NULL if only verification is desired.
+ *
+ * The given data _must_ be null-terminated.
+ */
int parse_and_verify_tag_buffer(struct tag *item,
const char *data, const unsigned long size, int thorough_verify)
This hunk really belongs into commit which introduced the function
parse_and_verify_tag_buffer.