Re: [dpdk-dev] [PATCH v15 11/12] build: add Arm SoC meson option
From: Juraj Linkeš <hidden>
Date: 2021-01-19 14:56:23
-----Original Message----- From: Thomas Monjalon <redacted> Sent: Monday, January 18, 2021 2:42 PM To: Juraj Linkeš <redacted> Cc: bruce.richardson@intel.com; Ruifeng.Wang@arm.com; Honnappa.Nagarahalli@arm.com; Phil.Yang@arm.com; vcchunga@amazon.com; Dharmik.Thakkar@arm.com; jerinjacobk@gmail.com; hemant.agrawal@nxp.com; ajit.khaparde@broadcom.com; ferruh.yigit@intel.com; aboyer@pensando.io; dev@dpdk.org Subject: Re: [dpdk-dev] [PATCH v15 11/12] build: add Arm SoC meson option 15/01/2021 14:26, Juraj Linkeš:quoted
Add Arm SoC configuration to Arm meson.build and add a meson option to enable those options for native builds. This is preferable to specifying a cross file when doing aarch64 -> aarch64 builds, since the cross file specifies the toolchain as well. Signed-off-by: Juraj Linkeš <redacted> Reviewed-by: Honnappa Nagarahalli <redacted>[...]quoted
--- a/config/arm/arm64_graviton2_linux_gcc +++ b/config/arm/arm64_graviton2_linux_gcc [properties] -implementor_id = '0x41' -implementor_pn = '0xd0c' -max_lcores = 64 -max_numa_nodes = 1 -numa = false +soc = 'graviton2'[...]quoted
--- a/meson_options.txt +++ b/meson_options.txt +option('arm_soc', type: 'string', value: '', + description: 'Specify if you want to build for a particular aarch64 +Arm SoC when building on an aarch64 machine.')This is more elegant, I like how cross and native share almost the same option. Why the option is named "arm_soc" and not just "soc"? The same option could be used by other archs, isn't it?
Agree that a more generic name would be better. I'll change it to "soc" if there are no other suggestions.