Thread (33 messages) 33 messages, 3 authors, 2022-03-22

Re: [PATCH 4/6] i2c: mux: pinctrl: remove CONFIG_OF dependency and use fwnode API

From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Date: 2022-03-18 18:24:34
Also in: linux-acpi, linux-i2c, lkml

On Fri, Mar 18, 2022 at 05:56:30PM +0100, Clément Léger wrote:
Le Fri, 18 Mar 2022 18:28:45 +0200,
Andy Shevchenko [off-list ref] a écrit :
quoted
On Fri, Mar 18, 2022 at 05:00:50PM +0100, Clément Léger wrote:
quoted
In order to use i2c muxes with software_node when added with a struct
mfd_cell, switch to fwnode API. The fwnode layer will allow to use this
with both device_node and software_node.  
quoted
-	struct device_node *np = dev->of_node;
+	struct fwnode_handle *np = dev_fwnode(dev);  
np is now a misleading name. Use fwnode.
Ok I thought np was meaning "node pointer" and it looked like okay to
avoid avoid a diff that is too huge. But agreed, I'll rename that.
It's rather "in practice", np stands for "OF node pointer", while fwnode
stands for "firmware node handle".

-- 
With Best Regards,
Andy Shevchenko

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help