Le Fri, 18 Mar 2022 18:28:45 +0200,
Andy Shevchenko [off-list ref] a écrit :
On Fri, Mar 18, 2022 at 05:00:50PM +0100, Clément Léger wrote:
quoted
In order to use i2c muxes with software_node when added with a struct
mfd_cell, switch to fwnode API. The fwnode layer will allow to use this
with both device_node and software_node.
quoted
- struct device_node *np = dev->of_node;
+ struct fwnode_handle *np = dev_fwnode(dev);
np is now a misleading name. Use fwnode.
Ok I thought np was meaning "node pointer" and it looked like okay to
avoid avoid a diff that is too huge. But agreed, I'll rename that.
--
Clément Léger,
Embedded Linux and Kernel engineer at Bootlin
https://bootlin.com