Re: [PATCH 07/10] ravb: Add tsrq to struct ravb_hw_info
From: Sergey Shtylyov <hidden>
Date: 2021-10-04 18:54:34
Also in:
linux-renesas-soc
On 10/4/21 9:47 PM, Biju Das wrote: [...]
quoted
quoted
The TCCR bits are called transmit start request (queue 0/1), nottransmit start request queue 0/1.quoted
I think you've read too much value into them for what is just TX queue0/1.quoted
quoted
Add a tsrq variable to struct ravb_hw_info to handle this difference. Signed-off-by: Biju Das <biju.das.jz@bp.renesas.com> Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com> --- RFC->v1: * Added tsrq variable instead of multi_tsrq feature bit. --- drivers/net/ethernet/renesas/ravb.h | 1 + drivers/net/ethernet/renesas/ravb_main.c | 9 +++++++-- 2 files changed, 8 insertions(+), 2 deletions(-)diff --git a/drivers/net/ethernet/renesas/ravb.hb/drivers/net/ethernet/renesas/ravb.h index 9cd3a15743b4..c586070193ef 100644--- a/drivers/net/ethernet/renesas/ravb.h +++ b/drivers/net/ethernet/renesas/ravb.h@@ -997,6 +997,7 @@ struct ravb_hw_info { netdev_features_t net_features; int stats_len; size_t max_rx_len; + u32 tsrq;I'd call it 'tccr_value' instead.Or even better, 'tccr_mask'...We are not masking anything here right.
We do -- we pass the TCCR mask to ravb_wait().
[...]
Regards, Biju
MBR, Sergey