RE: [PATCH 07/10] ravb: Add tsrq to struct ravb_hw_info
From: Biju Das <biju.das.jz@bp.renesas.com>
Date: 2021-10-04 18:47:58
Also in:
linux-renesas-soc
-----Original Message----- From: Sergei Shtylyov <redacted> Sent: 04 October 2021 19:37 To: Sergey Shtylyov <redacted>; Biju Das [off-list ref]; David S. Miller [off-list ref]; Jakub Kicinski [off-list ref] Cc: Geert Uytterhoeven <geert+renesas@glider.be>; Sergey Shtylyov [off-list ref]; Adam Ford [off-list ref]; Andrew Lunn [off-list ref]; Yuusuke Ashizuka [off-list ref]; Yoshihiro Shimoda [off-list ref]; netdev@vger.kernel.org; linux- renesas-soc@vger.kernel.org; Chris Paterson [off-list ref]; Biju Das [off-list ref]; Prabhakar Mahadev Lad [off-list ref] Subject: Re: [PATCH 07/10] ravb: Add tsrq to struct ravb_hw_info On 10/4/21 9:00 PM, Sergey Shtylyov wrote: [...]quoted
The TCCR bits are called transmit start request (queue 0/1), nottransmit start request queue 0/1.quoted
I think you've read too much value into them for what is just TX queue0/1.quoted
quoted
Add a tsrq variable to struct ravb_hw_info to handle this difference. Signed-off-by: Biju Das <biju.das.jz@bp.renesas.com> Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com> --- RFC->v1: * Added tsrq variable instead of multi_tsrq feature bit. --- drivers/net/ethernet/renesas/ravb.h | 1 + drivers/net/ethernet/renesas/ravb_main.c | 9 +++++++-- 2 files changed, 8 insertions(+), 2 deletions(-)diff --git a/drivers/net/ethernet/renesas/ravb.hb/drivers/net/ethernet/renesas/ravb.h index 9cd3a15743b4..c586070193ef 100644--- a/drivers/net/ethernet/renesas/ravb.h +++ b/drivers/net/ethernet/renesas/ravb.h@@ -997,6 +997,7 @@ struct ravb_hw_info { netdev_features_t net_features; int stats_len; size_t max_rx_len; + u32 tsrq;I'd call it 'tccr_value' instead.Or even better, 'tccr_mask'...
We are not masking anything here right. tccr_value will be ok, as it implies real tccr register value. Regards, Biju
[...] MBR, Sergey