Thread (25 messages) 25 messages, 7 authors, 2019-09-19

Re: [PATCH RFC v3 2/5] net: Add NETIF_F_GRO_LIST feature

From: Steffen Klassert <steffen.klassert@secunet.com>
Date: 2019-09-19 09:24:51

On Wed, Sep 18, 2019 at 12:10:31PM -0400, Willem de Bruijn wrote:
On Wed, Sep 18, 2019 at 3:25 AM Steffen Klassert
[off-list ref] wrote:
quoted
This adds a new NETIF_F_GRO_LIST feature flag. I will be used
to configure listfyed GRO what will be implemented with some
followup paches.
This should probably simultaneously introduce SKB_GSO_FRAGLIST as well
as a BUILD_BUG_ON in net_gso_ok.
Yes, good point. I'll also rename NETIF_F_GRO_LIST to NETIF_F_GRO_FRAGLIST
and add NETIF_F_GSO_FRAGLIST what is currently missing.
Please also in the commit describe the constraints of skbs that have
this type. If I'm not mistaken, an skb with either gso_size linear
data or one gso_sized frag, followed by a frag_list of the same. With
the exception of the last frag_list member, whose mss may be less than
gso_size. This will help when reasoning about all the types of skbs we
may see at segmentation, as we recently had to do [1]
We don't use skb_segment(), so I think we don't have this constraint.
Minor nit: I think it's listified, not listifyed.
I think neither of both words really exist :)
I'll rename it to fraglist GRO.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help