Thread (37 messages) 37 messages, 4 authors, 2021-02-08

Re: [PATCH v4 11/23] powerpc/syscall: Rename syscall_64.c into syscall.c

From: Christophe Leroy <hidden>
Date: 2021-02-02 06:16:15
Also in: lkml


Le 28/01/2021 à 00:50, Nicholas Piggin a écrit :
Excerpts from David Laight's message of January 26, 2021 8:28 pm:
quoted
From: Nicholas Piggin
quoted
Sent: 26 January 2021 10:21

Excerpts from Christophe Leroy's message of January 26, 2021 12:48 am:
quoted
syscall_64.c will be reused almost as is for PPC32.

Rename it syscall.c
Could you rename it to interrupt.c instead? A system call is an
interrupt, and the file now also has code to return from other
interrupts as well, and it matches the new asm/interrupt.h from
the interrupts series.
Hmmm....

That might make it harder for someone looking for the system call
entry code to find it.
It's very grep'able.
quoted
In some sense interrupts are the simpler case.

Especially when comparing with other architectures which have
special instructions for syscall entry.
powerpc does have a special instruction for syscall, and it causes a
system call interrupt.

I'm not sure about other architectures, but for powerpc its more
sensible to call it interrupt.c than syscall.c.
Many other architectures have a syscall.c but for a different purpose: it contains arch specific 
system calls. We have that in powerpc as well, it is called syscalls.c

So to avoid confusion, I'll rename it. But I think "interrupt" is maybe not the right name. An 
interrupt most of the time refers to IRQ. For me system call is not an interrupt in the way it 
doesn't unexpectedly interrupt a program flow. In powerpc manuals it is generally called exceptions, 
no I'm more inclined to call it exception.c

Christophe
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help