Re: [PATCH v4 11/23] powerpc/syscall: Rename syscall_64.c into syscall.c
From: Nicholas Piggin <npiggin@gmail.com>
Date: 2021-01-26 11:38:01
Also in:
lkml
From: Nicholas Piggin <npiggin@gmail.com>
Date: 2021-01-26 11:38:01
Also in:
lkml
Excerpts from Christophe Leroy's message of January 26, 2021 12:48 am:
syscall_64.c will be reused almost as is for PPC32. Rename it syscall.c
Could you rename it to interrupt.c instead? A system call is an interrupt, and the file now also has code to return from other interrupts as well, and it matches the new asm/interrupt.h from the interrupts series. Thanks, Nick