From: Nicholas Piggin
Sent: 26 January 2021 10:21
Excerpts from Christophe Leroy's message of January 26, 2021 12:48 am:
quoted
syscall_64.c will be reused almost as is for PPC32.
Rename it syscall.c
Could you rename it to interrupt.c instead? A system call is an
interrupt, and the file now also has code to return from other
interrupts as well, and it matches the new asm/interrupt.h from
the interrupts series.
Hmmm....
That might make it harder for someone looking for the system call
entry code to find it.
In some sense interrupts are the simpler case.
Especially when comparing with other architectures which have
special instructions for syscall entry.
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)