On Thursday 26 April 2007, Mark A. Greer wrote:
+void __init mv64x60_pci_init(void)
+{
+=A0=A0=A0=A0=A0=A0=A0struct device_node *np =3D NULL;
+
+=A0=A0=A0=A0=A0=A0=A0ppc_md.pci_exclude_device =3D mv64x60_exclude_devic=
e;
+
+=A0=A0=A0=A0=A0=A0=A0while ((np =3D of_find_compatible_node(np, "pci", "=
mv64x60-pci")))
+=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0mv64x60_add_bridge(np);
+}
This is a similar mistake to the previous two, but somewhat different:
You actually duplicate code that is already present in of_platform.c.
AFAICS, all you should need to do is implement the ppc_md.pci_setup_phb()
function instead of your own handmade device tree scanning.
Arnd <><