Re: [PATCH v8 01/15] khugepaged: rename hpage_collapse_* to khugepaged_*
From: David Hildenbrand <hidden>
Date: 2025-07-08 15:57:38
Also in:
linux-doc, linux-mm, lkml
On 04.07.25 07:14, Dev Jain wrote:
On 02/07/25 11:27 am, Nico Pache wrote:quoted
functions in khugepaged.c use a mix of hpage_collapse and khugepaged as the function prefix. rename all of them to khugepaged to keep things consistent and slightly shorten the function names. Reviewed-by: Zi Yan <ziy@nvidia.com> Reviewed-by: Baolin Wang <baolin.wang@linux.alibaba.com> Signed-off-by: Nico Pache <npache@redhat.com> ---You are essentially reverting commit 7d8faaf15545 which adds the hpage_collapse_ prefix. Since in the next patch you also unify madvise and khugepaged, removing hpage_collapse prefix would make sense, but then I tend to agree with Liam that dropping the prefix altogether is better. Having all the functions in khugepaged.c prefixed with khugepaged_ seems unnecessary work.
Yeah. Or just "collapse_". Anything is better than this "hpage" stuff.
@David, I forgot where you replied but I remember you saying that we should not introduce MADV_COLLAPSE mTHP support for now?
Yes, that's what Lorenzo and me discussed. Better to keep it at PMDs for now, as that's what the current interface promises. In theory, we could do something like the following without causing too much trouble: Collapse to the largest THP spanned by the range. I.e., when collapsing a 2M aligned range, only use a 2M THP. when collapsing a 64K aligned range, only use a 64K THP. etc. Because that would keep existing behavior mostly unchanged. But I would defer all that for now ... -- Cheers, David / dhildenb