Re: [PATCH v8 01/15] khugepaged: rename hpage_collapse_* to khugepaged_*
From: Nico Pache <npache@redhat.com>
Date: 2025-07-08 04:36:19
Also in:
linux-doc, linux-mm, lkml
On Thu, Jul 3, 2025 at 11:14 PM Dev Jain [off-list ref] wrote:
On 02/07/25 11:27 am, Nico Pache wrote:quoted
functions in khugepaged.c use a mix of hpage_collapse and khugepaged as the function prefix. rename all of them to khugepaged to keep things consistent and slightly shorten the function names. Reviewed-by: Zi Yan <ziy@nvidia.com> Reviewed-by: Baolin Wang <baolin.wang@linux.alibaba.com> Signed-off-by: Nico Pache <npache@redhat.com> ---You are essentially reverting commit 7d8faaf15545 which adds the hpage_collapse_ prefix. Since in the next patch you also unify madvise and khugepaged, removing hpage_collapse prefix would make sense, but then I tend to agree with Liam that dropping the prefix altogether is better. Having all the functions in khugepaged.c prefixed with khugepaged_ seems unnecessary work.
Ah thanks for pointing that out, I didn't realize they were already once named khugepaged. Makes sense, since there is opposition, and a good reason to have them as hpage_collapse (or collapse) I'll consider either dropping this patch, or changing it to "collapse_". tbh I didn't realize that was what Liam was suggesting, I thought he was suggesting dropping the hpage_collapse entirely.
@David, I forgot where you replied but I remember you saying that we should not introduce MADV_COLLAPSE mTHP support for now?
Yeah Baolin pointed me to that thread (https://lore.kernel.org/all/23b8ad10-cd1f-45df-a25c-78d01c8af44f@redhat.com/ (local)) I read most of that discussion as it was happening but missed that point. I'll add the small change I need to drop the MADV_COLLAPSE support and send a V9 in a few days (to gather more review). Adding MADV_COLLAPSE support should be easy once/if we come to a consensus on what the proper approach is. Thanks, -- Nico