Thread (30 messages) flat view 30 messages, 6 authors, 2025-07-11

Re: [PATCH v8 01/15] khugepaged: rename hpage_collapse_* to khugepaged_*

From: Dev Jain <dev.jain@arm.com>
Date: 2025-07-04 05:14:48
Also in: linux-doc, linux-mm, lkml

On 02/07/25 11:27 am, Nico Pache wrote:
functions in khugepaged.c use a mix of hpage_collapse and khugepaged
as the function prefix.

rename all of them to khugepaged to keep things consistent and slightly
shorten the function names.

Reviewed-by: Zi Yan <ziy@nvidia.com>
Reviewed-by: Baolin Wang <baolin.wang@linux.alibaba.com>
Signed-off-by: Nico Pache <redacted>
---
  
You are essentially reverting commit 7d8faaf15545 which adds the
hpage_collapse_ prefix. Since in the next patch you also unify
madvise and khugepaged, removing hpage_collapse prefix would
make sense, but then I tend to agree with Liam that dropping
the prefix altogether is better. Having all the functions in
khugepaged.c prefixed with khugepaged_ seems unnecessary work.

@David, I forgot where you replied but I remember you saying
that we should not introduce MADV_COLLAPSE mTHP support for
now?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help