On Wed, May 13, 2020 at 12:28 AM Serge Semin
[off-list ref] wrote:
On Fri, May 08, 2020 at 10:43:24PM +0300, Andy Shevchenko wrote:
quoted
On Fri, May 08, 2020 at 04:29:29PM +0300, Serge Semin wrote:
quoted
Since from now the former Intel MID platform layer will be used
as a generic DW SPI DMA module, lets alter the internal methods
naming to be DMA-related instead of having the "mid_" prefix. In
addition the DW PCI-DMA specific methods and structures should
be named with pci-suffexes, since we'll implement the DW MMIO DMA
specific functions and objects soon.
I think we rather leave Intel Medfield things alone. And I think I did this already in spi/for-next in less invasive way.
The naming is horrible in that module.
I agree!
Since it's going to be a generic DMA
driver the prefixes should be correspondingly fixed. Currently they are a bit
random.
Unfortunately, proposed '_pci' not anyhow better. There is Medfield
stuff and non-Medfield.
Luckily Elkhart Lake uses generic approach. That's why better to have
suffix based on platform, rather than on bus.
I think what should be done here are (in a patch per item):
1) moving to new named module (w/o mid)
2) removing mid_ prefix
3) something else I forgot?
--
With Best Regards,
Andy Shevchenko