On Wed, Jun 7, 2017 at 11:10 PM, Sakari Ailus [off-list ref] wrote:
On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote:
quoted
On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus [off-list ref] wrote:
quoted
On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote:
quoted
quoted
quoted
Follow the pattern, please, I suppose
ti_pmic_tps68470.c
Would it work for you?
This is still a different driver from the tps68470 driver which is an MFD
driver. For clarity, I'd keep pmic as part of the name (and I'd use
tps68470_pmic_ prefix for internal symbols, too).
As PMICs are typically linked to the kernel (vs. being modules), there's no
issue with the module name. I would suppose few if any PMICs will be
compiled as modules in general.
It's not a big deal though. I'm fine either way.
Okay, let's agree on tps68470_pmic for internal prefix and for file name?
--
With Best Regards,
Andy Shevchenko