Maybe matter of taste but cold this be named hci_conn_ssp_supported ?
Then in if condition below it would be seen more natural and similar to
other "-ed" functions.
Based on Marcel's preference for the define names it will be called
hci_conn_ssp_enabled.
Johan