Thread (40 messages) 40 messages, 3 authors, 2022-04-22

Re: [PATCH V2 06/12] clk: mediatek: reset: Revise structure to control reset register

From: Rex-BC Chen <hidden>
Date: 2022-04-22 05:04:23
Also in: linux-clk, linux-mediatek, lkml

On Thu, 2022-04-21 at 11:07 +0200, AngeloGioacchino Del Regno wrote:
Il 20/04/22 15:05, Rex-BC Chen ha scritto:
quoted
Add mtk_clk_rst_desc to input the reset register data, and replace
the
structure "struct mtk_reset" to reset.h, and rename it as
"mtk_clk_rst_data". We use them to store reset register data and
store reset controller device.

Signed-off-by: Rex-BC Chen <redacted>
---
  drivers/clk/mediatek/clk-mt2701-eth.c |  8 +++++-
  drivers/clk/mediatek/clk-mt2701-g3d.c |  8 +++++-
  drivers/clk/mediatek/clk-mt2701-hif.c |  8 +++++-
  drivers/clk/mediatek/clk-mt2701.c     | 19 ++++++++++++--
  drivers/clk/mediatek/clk-mt2712.c     | 19 ++++++++++++--
  drivers/clk/mediatek/clk-mt7622-eth.c |  8 +++++-
  drivers/clk/mediatek/clk-mt7622-hif.c | 10 ++++++--
  drivers/clk/mediatek/clk-mt7622.c     | 19 ++++++++++++--
  drivers/clk/mediatek/clk-mt7629-eth.c |  8 +++++-
  drivers/clk/mediatek/clk-mt7629-hif.c | 10 ++++++--
  drivers/clk/mediatek/clk-mt8135.c     | 19 ++++++++++++--
  drivers/clk/mediatek/clk-mt8173.c     | 19 ++++++++++++--
  drivers/clk/mediatek/clk-mt8183.c     |  9 +++++--
  drivers/clk/mediatek/reset.c          | 36 +++++++++++++---------
-----
  drivers/clk/mediatek/reset.h          | 15 ++++++++++-
  15 files changed, 174 insertions(+), 41 deletions(-)
..snip..
quoted
diff --git a/drivers/clk/mediatek/reset.c
b/drivers/clk/mediatek/reset.c
index 8e42deee80a3..d67c13958458 100644
--- a/drivers/clk/mediatek/reset.c
+++ b/drivers/clk/mediatek/reset.c
@@ -14,25 +14,19 @@
  
  #include "clk-mtk.h"
  
-struct mtk_reset {
-	struct regmap *regmap;
-	int regofs;
-	struct reset_controller_dev rcdev;
-};
-
-static inline struct mtk_reset *to_rst_data(struct
reset_controller_dev *rcdev)
+static inline struct mtk_clk_rst_data *to_rst_data(struct
reset_controller_dev *rcdev)
  {
to_mtk_clk_rst_data()...
by the way, it's probably better if you introduce this helper here
directly,
instead of introducing it in commit 03/12 and changing it entirely in
06/12.

The rest of the code looks good to me, I'm sure that you'll get my R-
b in the
next version.
Hello Angelo,

I will do this in next version.
Thanks!

BRs,
Rex


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help