Thread (40 messages) 40 messages, 3 authors, 2022-04-22

Re: [PATCH V2 03/12] clk: mediatek: reset: Refine functions of set_clr

From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
Date: 2022-04-21 09:08:21
Also in: linux-clk, linux-mediatek, lkml

Il 20/04/22 15:05, Rex-BC Chen ha scritto:
quoted hunk ↗ jump to hunk
To make driver more readable, revise functions of set_clr.
- Add to_rst_data().
- Extract common code within assert and deassert to
   mtk_reset_update_set_clr().

Signed-off-by: Rex-BC Chen <redacted>
---
  drivers/clk/mediatek/reset.c | 32 +++++++++++++++++++++-----------
  1 file changed, 21 insertions(+), 11 deletions(-)
diff --git a/drivers/clk/mediatek/reset.c b/drivers/clk/mediatek/reset.c
index 9110d0b4229f..6574b19daf0f 100644
--- a/drivers/clk/mediatek/reset.c
+++ b/drivers/clk/mediatek/reset.c
@@ -20,26 +20,36 @@ struct mtk_reset {
  	struct reset_controller_dev rcdev;
  };
  
-static int mtk_reset_assert_set_clr(struct reset_controller_dev *rcdev,
-	unsigned long id)
+static inline struct mtk_reset *to_rst_data(struct reset_controller_dev *rcdev)
to_mtk_reset() looks more consistent, as many developers are using the naming
"to_{struct_name}".

Also, can you please mention the indentation fixes in the commit description?

Thanks,
Angelo


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help