Thread (9 messages) flat view 9 messages, 4 authors, 2016-03-10

[PATCH RESEND] Documentation: devicetree: Clean up gpio-keys example

From: Julien Chauveau <hidden>
Date: 2016-03-08 09:41:50
Also in: linux-devicetree, linux-input, linux-rockchip, lkml

Le 8 mars 2016 ? 09:54, Geert Uytterhoeven [off-list ref] a ?crit :

On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.

Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
diff --git a/Documentation/devicetree/bindings/input/gpio-keys.txt b/Documentation/devicetree/bindings/input/gpio-keys.txt
index 21641236c095..1552a11f6786 100644
--- a/Documentation/devicetree/bindings/input/gpio-keys.txt
+++ b/Documentation/devicetree/bindings/input/gpio-keys.txt
@@ -34,8 +34,6 @@ Example nodes:

       gpio_keys {
                       compatible = "gpio-keys";
-                       #address-cells = <1>;
-                       #size-cells = <0>;
                       autorepeat;
                       button at 21 {
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:

Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
Hi Andreas,
This means you can also drop the unit-address (the @21 part) for the button.
What about using a more relevant name like "key_up" instead of "button"?

Julien
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help