From: Andreas Färber <afaerber@suse.de> Date: 2016-03-07 18:24:49
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
From: Javier Martinez Canillas <javier@dowhile0.org> Date: 2016-03-07 18:35:06
Hello Andreas,
On Mon, Mar 7, 2016 at 3:24 PM, Andreas F?rber [off-list ref] wrote:
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
Looks good to me.
Reviewed-by: Javier Martinez Canillas <redacted>
Best regards,
Javier
From: Andreas Färber <afaerber@suse.de> Date: 2016-03-07 19:25:40
Hi,
Am 07.03.2016 um 19:34 schrieb Javier Martinez Canillas:
On Mon, Mar 7, 2016 at 3:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
Looks good to me.
Reviewed-by: Javier Martinez Canillas <redacted>
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted hunk
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
label = "GPIO Key UP";
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert at linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Le 8 mars 2016 ? 09:54, Geert Uytterhoeven [off-list ref] a ?crit :
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
Hi Andreas,
This means you can also drop the unit-address (the @21 part) for the button.
What about using a more relevant name like "key_up" instead of "button"?
Julien
From: Andreas Färber <afaerber@suse.de> Date: 2016-03-08 10:09:35
Am 08.03.2016 um 09:54 schrieb Geert Uytterhoeven:
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
Also a white line here may be optically more pleasant.
quoted
button at 21 {
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
My v2 GeekBox patch did have *-cells and a reg property, but Julien
asked I drop that: https://patchwork.kernel.org/patch/8246481/
Are you suggesting we should add a reg property here and drop this patch
or go with this patch but follow up to not use @21?
quoted
label = "GPIO Key UP";
Regards,
Andreas
--
SUSE Linux GmbH, Maxfeldstr. 5, 90409 N?rnberg, Germany
GF: Felix Imend?rffer, Jane Smithard, Graham Norton; HRB 21284 (AG N?rnberg)
From: Andreas Färber <afaerber@suse.de> Date: 2016-03-08 10:16:40
Am 08.03.2016 um 10:41 schrieb Julien Chauveau:
Le 8 mars 2016 ? 09:54, Geert Uytterhoeven [off-list ref] a ?crit :
quoted
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
Hi Andreas,
This means you can also drop the unit-address (the @21 part) for the button.
What about using a more relevant name like "key_up" instead of "button"?
Or in my case power-key or power-button. Or would just power suffice?
The Landingship baseboard does have four more buttons not yet enabled,
so I do need some way to distinguish nodes.
Regards,
Andreas
--
SUSE Linux GmbH, Maxfeldstr. 5, 90409 N?rnberg, Germany
GF: Felix Imend?rffer, Jane Smithard, Graham Norton; HRB 21284 (AG N?rnberg)
Le 8 mars 2016 ? 11:16, Andreas F?rber [off-list ref] a ?crit :
Am 08.03.2016 um 10:41 schrieb Julien Chauveau:
quoted
Le 8 mars 2016 ? 09:54, Geert Uytterhoeven [off-list ref] a ?crit :
quoted
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
Hi Andreas,
This means you can also drop the unit-address (the @21 part) for the button.
What about using a more relevant name like "key_up" instead of "button"?
Or in my case power-key or power-button. Or would just power suffice?
For the example nodes of the documentation, according to the labels you?ll probably want to use "up" and "down" (or "key-up" and "key-down", or "up-key" and "down-key").
For the Geekbox, I think "power" is meaningful enough.
The Landingship baseboard does have four more buttons not yet enabled,
so I do need some way to distinguish nodes.
The labels on the board are key1, key2, key3 and key4. Maybe you can use that?
Le 8 mars 2016 ? 11:09, Andreas F?rber [off-list ref] a ?crit :
Am 08.03.2016 um 09:54 schrieb Geert Uytterhoeven:
quoted
On Mon, Mar 7, 2016 at 7:24 PM, Andreas F?rber [off-list ref] wrote:
quoted
Drop #address-cells and #size-cells, which are not required by the
gpio-keys binding documentation, as button sub-nodes are not devices.
Reported-by: Julien Chauveau <redacted>
Signed-off-by: Andreas F?rber <afaerber@suse.de>
---
Documentation/devicetree/bindings/input/gpio-keys.txt | 2 --
1 file changed, 2 deletions(-)
Also a white line here may be optically more pleasant.
I agree.
quoted
quoted
button at 21 {
FYI, with "[PATCH] scripts/dtc: Update to upstream version 53bf130b1cdd":
(http://www.spinics.net/lists/devicetree/msg117206.html) applied:
Warning (unit_address_vs_reg): Node /keyboard/button at 21 has a unit
name, but no reg property
My v2 GeekBox patch did have *-cells and a reg property, but Julien
asked I drop that: https://patchwork.kernel.org/patch/8246481/
Are you suggesting we should add a reg property here and drop this patch
or go with this patch but follow up to not use @21?
I may be wrong but I think that if the unit-address has no meaning and is not used, then it should be removed.
By the way, I think the warning message is wrong. It should be _address_ instead of name: "Node has a unit address, but no reg property".
Julien