Jeff King [off-list ref] writes:
I think the "after the dust settles" suggestion was for changing the
interface of "struct object_info". That all becomes moot if we stop
using it here entirely. So I think you should proceed along the lines of
the object_info_results you showed above.
OK, if we are not using object_info structure at all, then I do not
think it matters all that much if it is a struct of arrays or an
array of structs (even though I suspect the latter would be
cleaner).
But I'd rather see it named differently, leaving no room to be
confused with the existing object_info structure.
Thanks.