Thread (27 messages) flat view 27 messages, 7 authors, 2016-06-15

Re: [PATCH 2/2] git-gui: some French translation enhancements

From: Christian Couder <hidden>
Date: 2016-06-15 22:46:26

Le vendredi 20 mars 2009, Alexandre Bourget a écrit :
Le vendredi 20 mars 2009 à 08:13 +0100, Mike Hommey a écrit :
quoted
On Fri, Mar 20, 2009 at 01:54:02AM +0100, Nicolas Sebrecht wrote:
IMHO, we should find a better way to say that than to use the "index"
word at all. This obviously applies to all uses of "index" in french
where we avoided it in english.

OTOH, the best I can find for "staging area" is "zone de préparation",
and that doesn't help finding a word for stage and unstage.
"zone de préparation" sounds good to me.


-------------
quoted
[from another e-mail]
quoted
We should care that the revert operation does *not* remove a commit
but add a new one (this makes sense to Git). As a consequence, we
should avoid "Annuler", "Révoquer" and "Défaire".

"Inverser" looks like the best translation.
Yeah, I agree with that reasoning.
Hmm.. if you look at the git-gui program, when we use "Revert", it's not
always the usage of the git-revert command that is invoked.

Most of the time, it's the equivalent of running "git reset --hard", or
"git checkout path/filename.ext" (in fact, it uses git-checkout-index,
see git-gui/lib/index.tcl::revert_helper..).

That is true for example in the "Commit" menu, 3rd to last item, which
reads in french "Inverser les modifications" or "Révoker les
modifications" as I modified it at some point.

What happens here, is really not inversion of modifications; we're just
wiping out all changes from the working dir, back to HEAD. Several of
the translated messages are used in *that* context.


So, considering this, which one of: "Annuler", "Révoquer", "Défaire",
"Effacer", "Restaurer l'original", "Scrapper", "Trucider", "Supprimer" +
"les modifications" would be best ?
Considering what you said, I think "Annuler" is best, but we really should 
remove "(revert)"  in "Annuler les modifications (revert)" as it is 
definitely misleading translators ;-)

Sam could you please send a newer version of you original patch with the 
above change and:

s/Essayez de récupéré/Essayez de récupérer/
s/selectionnés/sélectionnés/

About the index/staging area/adding/staging/unstaging, I think there is not 
yet an agreeement about how we should translate that so we should discuss 
it further.

Thanks,
Christian.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help