Re: [PATCH v4 1/7] service cores: header and implementation
From: Van Haaren, Harry <hidden>
Date: 2017-07-11 12:49:27
From: Jerin Jacob [mailto:jerin.jacob@caviumnetworks.com] Sent: Tuesday, July 11, 2017 1:45 PM To: Van Haaren, Harry <redacted> Cc: Thomas Monjalon <redacted>; dev@dpdk.org; Wiles, Keith [off-list ref]; Richardson, Bruce [off-list ref] Subject: Re: [PATCH v4 1/7] service cores: header and implementation
<snip>
quoted
The service registration API should be exposed to the application. Imagine a use case where the application wants to run services *and* an applicationspecific function on the same core. In the current implementation this is possible, as the application can register a service. The app then configures all services (including its own "app-service") to run on a service lcore.quoted
If we hide the service registration from the application, we make it impossible for theapplication to multiplex services and application specific workloads on a single core. Then we could move the registration functions to service.h. IMO, It does not look correct if we expose _prviate.h to application or we could rename to service_component.h or something like that.
Fair enough - I will rename to rte_service_component.h for v5. Thanks for input!