[PATCH net-next 0/9] ptp .adjphase cleanups
From: Rahul Rameshbabu <rrameshbabu@nvidia.com>
Date: 2023-05-10 21:01:27
The goal of this patch series is to improve documentation of .adjphase, add a new callback .getmaxphase to enable advertising the max phase offset a device PHC can support, and support invoking .adjphase from the testptp kselftest. Link: https://lore.kernel.org/netdev/20230120160609.19160723@kernel.org/ (local) Rahul Rameshbabu (9): ptp: Clarify ptp_clock_info .adjphase expects an internal servo to be used docs: ptp.rst: Add information about NVIDIA Mellanox devices testptp: Remove magic numbers related to nanosecond to second conversion testptp: Add support for testing ptp_clock_info .adjphase callback ptp: Add .getmaxphase callback to ptp_clock_info net/mlx5: Add .getmaxphase ptp_clock_info callback ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback ptp: idt82p33: Add .getmaxphase ptp_clock_info callback ptp: ocp: Add .getmaxphase ptp_clock_info callback Documentation/driver-api/ptp.rst | 30 ++++++++++++++++ .../ethernet/mellanox/mlx5/core/lib/clock.c | 31 ++++++++-------- drivers/ptp/ptp_chardev.c | 5 ++- drivers/ptp/ptp_clock.c | 4 +++ drivers/ptp/ptp_clockmatrix.c | 36 +++++++++---------- drivers/ptp/ptp_clockmatrix.h | 2 +- drivers/ptp/ptp_idt82p33.c | 18 +++++----- drivers/ptp/ptp_idt82p33.h | 4 +-- drivers/ptp/ptp_ocp.c | 7 ++++ drivers/ptp/ptp_sysfs.c | 12 +++++++ include/linux/ptp_clock_kernel.h | 11 ++++-- include/uapi/linux/ptp_clock.h | 3 +- tools/testing/selftests/ptp/testptp.c | 29 ++++++++++++--- 13 files changed, 136 insertions(+), 56 deletions(-) -- 2.38.4