Re: [PATCH net-next v2 2/8] ravb: Add skb_sz to struct ravb_hw_info
From: Sergei Shtylyov <hidden>
Date: 2021-08-02 20:55:03
Also in:
linux-renesas-soc
From: Sergei Shtylyov <hidden>
Date: 2021-08-02 20:55:03
Also in:
linux-renesas-soc
On 8/2/21 1:26 PM, Biju Das wrote:
The maximum descriptor size that can be specified on the reception side for R-Car is 2048 bytes, whereas for RZ/G2L it is 8096. Add the skb_size variable to struct ravb_hw_info for allocating different skb buffer sizes for R-Car and RZ/G2L using the netdev_alloc_skb function. Signed-off-by: Biju Das <biju.das.jz@bp.renesas.com> Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com> --- v2: * Incorporated Andrew and Sergei's review comments for making it smaller patch and provided detailed description. --- drivers/net/ethernet/renesas/ravb.h | 1 + drivers/net/ethernet/renesas/ravb_main.c | 10 ++++++---- 2 files changed, 7 insertions(+), 4 deletions(-)diff --git a/drivers/net/ethernet/renesas/ravb.h b/drivers/net/ethernet/renesas/ravb.h index cfb972c05b34..16d1711a0731 100644 --- a/drivers/net/ethernet/renesas/ravb.h +++ b/drivers/net/ethernet/renesas/ravb.h@@ -991,6 +991,7 @@ enum ravb_chip_id { struct ravb_hw_info { enum ravb_chip_id chip_id; int num_tx_desc; + size_t skb_sz;
Bad naming -- refers to software ISO hatdware, I suggest max_rx_len or s/th of that sort. [...] MBR, Sergei