Thread (18 messages) flat view 18 messages, 3 authors, 2007-07-20

Re: [PATCH 2/2] net/core: some functions' definition order adjustment for readability

From: Patrick McHardy <hidden>
Date: 2007-07-18 12:40:13
Also in: lkml

This could be done in the patch moving it .. anyways,


Denis Cheng wrote:
+#ifdef CONFIG_PROC_FS
+static void *dev_mc_seq_start(struct seq_file *seq, loff_t *pos)

If you're interested in doing more work, it would be nice to
generalize the seq-file functions for unicast and multicast
address lists and add /proc/net/dev_unicast or something like
that.

OTOH we could also export this using rtnetlink. The main reason
why I didn't do that is that it can only be read, not changed,
but this is also true for statistics etc. Any opinions on this?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help