Krishna Kumar2 wrote:
Patrick McHardy [off-list ref] wrote on 07/20/2007 03:41:01 PM:
quoted
quoted
-static inline int qdisc_restart(struct net_device *dev)
+static inline int qdisc_restart(struct net_device *dev,
+ struct sk_buff_head *blist)
{
struct Qdisc *q = dev->qdisc;
struct sk_buff *skb;
- unsigned lockless;
+ unsigned getlock; /* whether we need to get lock or not */
Unrelated rename, please get rid of this to reduce the noise.
OK, I guess I should have sent that change earlier :) The reason to change
the name is to avoid (double-negative) checks like :
if (!lockless)
to
if (getlock).
I will remove these changes.
I guess you could put it in another patch. But frankly, I think
the biggest uglyness is the conditional locking, not naming or
double negation, so it won't really make the code any nicer :)