Re: [PASEMI] Nemo board doesn't recognize any ATA disks with the pci-v5.16 updates
From: Krzysztof Wilczyński <hidden>
Date: 2021-11-09 23:19:21
Also in:
linux-pci
[+CC Adding Robert for visibility] Hi Arnd, Thank you looking at this! Much appreciated.
quoted
quoted
You could attach the kernel config there, too, since it didn't make it to the mailing list (vger may discard them -- see http://vger.kernel.org/majordomo-info.html).Bjorn and I looked at which commits that went with a recent Pull Request from us might be causing this, but we are a little bit at loss, and were hoping that you could give us a hand in troubleshooting this.For reference, these are the patches in that branch that touch any interesting files, as most of the contents are for pci-controller drivers that are not used on powerpc at all: $ git log --no-merges --oneline 512b7931ad05..dda4b381f05d arch/powerpc/ drivers/of/ drivers/pci/*.[ch] include/linux/ acd61ffb2f16 PCI: Add ACS quirk for Pericom PI7C9X2G switches 978fd0056e19 PCI: of: Allow matching of an interrupt-map local to a PCI device 041284181226 of/irq: Allow matching of an interrupt-map local to an interrupt controller 0ab8d0f6ae3f irqdomain: Make of_phandle_args_to_fwspec() generally available 5ec0a6fcb60e PCI: Do not enable AtomicOps on VFs 7a41ae80bdcb PCI: pci-bridge-emul: Fix emulation of W1C bits fd1ae23b495b PCI: Prefer 'unsigned int' over bare 'unsigned' ff5d3bb6e16d PCI: Remove redundant 'rc' initialization 3331325c6347 PCI/VPD: Use pci_read_vpd_any() in pci_vpd_size() e1b0d0bb2032 PCI: Re-enable Downstream Port LTR after reset or hotplug ac8e3cef588c PCI/sysfs: Explicitly show first MSI IRQ for 'irq' 88dee3b0efe4 PCI: Remove unused pci_pool wrappers b5f9c644eb1b PCI: Remove struct pci_dev->driver 2a4d9408c9e8 PCI: Use to_pci_driver() instead of pci_dev->driver 4141127c44a9 powerpc/eeh: Use to_pci_driver() instead of pci_dev->driver f9a6c8ad4922 PCI/ERR: Reduce compile time for CONFIG_PCIEAER=n 43e85554d4ed xen/pcifront: Use to_pci_driver() instead of pci_dev->driver 34ab316d7287 xen/pcifront: Drop pcifront_common_process() tests of pcidev, pdrv 9f37ab0412eb PCI/switchtec: Add check of event support 5a72431ec318 powerpc/eeh: Use dev_driver_string() instead of struct pci_dev->driver->name ae232f0970ea PCI: Drop pci_device_probe() test of !pci_dev->driver 097d9d414433 PCI: Drop pci_device_remove() test of pci_dev->driver 8e9028b3790d PCI: Return NULL for to_pci_driver(NULL) 357df2fc0066 PCI: Use unsigned to match sscanf("%x") in pci_dev_str_match_path() bf2928c7a284 PCI/VPD: Add pci_read/write_vpd_any() b2105b9f39b5 PCI: Correct misspelled and remove duplicated words 7c3855c423b1 PCI: Coalesce host bridge contiguous apertures e0f7b1922358 PCI: Use kstrtobool() directly, sans strtobool() wrapper 36f354ec7bf9 PCI/sysfs: Return -EINVAL consistently from "store" functions 95e83e219d68 PCI/sysfs: Check CAP_SYS_ADMIN before parsing user input af9d82626c8f PCI/ACPI: Remove OSC_PCI_SUPPORT_MASKS and OSC_PCI_CONTROL_MASKS 9a0a1417d3bb PCI: Tidy comments 06dc660e6eb8 PCI: Rename pcibios_add_device() to pcibios_device_add() e3f4bd3462f6 PCI: Mark Atheros QCA6174 to avoid bus reset 3a19407913e8 PCI/P2PDMA: Apply bus offset correctly in DMA address calculation Out of these, I agree that most of them seem harmless, these would be the ones I'd try to look at more closely, or maybe revert for testing: 978fd0056e19 PCI: of: Allow matching of an interrupt-map local to a PCI device 041284181226 of/irq: Allow matching of an interrupt-map local to an interrupt controller e1b0d0bb2032 PCI: Re-enable Downstream Port LTR after reset or hotplug 7c3855c423b1 PCI: Coalesce host bridge contiguous apertures 3a19407913e8 PCI/P2PDMA: Apply bus offset correctly in DMA address calculation
Robert would you be able build a kernel without the patches Arnd singled out as potential curlprits? Might be expidite some troubleshooting saving a lot of time doing bisect. I wonder if this will help you with the following problem: https://lore.kernel.org/linux-pci/CAP145pjO9zdGgutHP=of0H+L1=nSz097zf73i7ZYm2-NWuwHhQ@mail.gmail.com/ (local) Krzysztof