On Thu, 2016-06-09 at 20:53 -0500, Scott Wood wrote:
On Wed, 2016-06-08 at 23:21 +1000, Michael Ellerman wrote:
quoted
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
s/4K/64K/
Ugh, yep sorry, the ifdef confused me:
#ifndef CONFIG_PPC_64K_PAGES
...
#else /* if CONFIG_PPC_64K_PAGES */
...
static inline void pte_free_kernel(struct mm_struct *mm, pte_t *pte)
{
pte_fragment_fre((unsigned long *)pte, 1);
}
...
#endif /* CONFIG_PPC_64K_PAGES */
Will update before committing.
cheers