From: Michael Ellerman <mpe@ellerman.id.au> Date: 2016-06-08 13:21:14
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
Fixes: 74701d5947a6 ("powerpc/mm: Rename function to indicate we are allocating fragments")
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
---
arch/powerpc/include/asm/nohash/64/pgalloc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
Can you share the .config. I will add it to the build test.
Fixes: 74701d5947a6 ("powerpc/mm: Rename function to indicate we are allocating fragments")
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
From: Michael Ellerman <mpe@ellerman.id.au> Date: 2016-06-09 00:08:56
On Wed, 2016-06-08 at 20:19 +0530, Aneesh Kumar K.V wrote:
Michael Ellerman [off-list ref] writes:
quoted
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
Can you share the .config. I will add it to the build test.
From: Scott Wood <oss@buserror.net> Date: 2016-06-10 01:53:11
On Wed, 2016-06-08 at 23:21 +1000, Michael Ellerman wrote:
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
From: Michael Ellerman <mpe@ellerman.id.au> Date: 2016-06-10 03:29:40
On Thu, 2016-06-09 at 20:53 -0500, Scott Wood wrote:
On Wed, 2016-06-08 at 23:21 +1000, Michael Ellerman wrote:
quoted
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
s/4K/64K/
Ugh, yep sorry, the ifdef confused me:
#ifndef CONFIG_PPC_64K_PAGES
...
#else /* if CONFIG_PPC_64K_PAGES */
...
static inline void pte_free_kernel(struct mm_struct *mm, pte_t *pte)
{
pte_fragment_fre((unsigned long *)pte, 1);
}
...
#endif /* CONFIG_PPC_64K_PAGES */
Will update before committing.
cheers
From: Michael Ellerman <mpe@ellerman.id.au> Date: 2016-06-14 03:18:34
On Wed, 2016-08-06 at 13:21:11 UTC, Michael Ellerman wrote:
Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are
allocating fragments" renamed page_table_free() to pte_fragment_free().
One occurrence was mistyped as pte_fragment_fre().
This only breaks the nohash 4K page build, which is not the default or
enabled in any defconfig.
Fixes: 74701d5947a6 ("powerpc/mm: Rename function to indicate we are allocating fragments")
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
Reviewed-by: Aneesh Kumar K.V <redacted>