Thread (37 messages) flat view 37 messages, 7 authors, 2014-09-15

Re: [PATCH v2 1/3] init/main.c: Give init_task a canary

From: Chuck Ebbert <hidden>
Date: 2014-09-10 07:27:02
Also in: lkml

On Tue,  9 Sep 2014 10:42:27 +0100
Aaron Tomlin [off-list ref] wrote:
+void task_stack_end_magic(struct task_struct *tsk)
+{
+	unsigned long *stackend;
+
+	stackend = end_of_stack(tsk);
+	*stackend = STACK_END_MAGIC;	/* for overflow detection */
+}
+
For clarity this should probably be called set_task_stack_end_magic().

And has this been tested on parisc and metag, which use STACK_GROWSUP ?
I can't see how end_of_stack() as it's defined now could work on those archs.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help