On Thu, 2012-06-07 at 16:05 +1000, Michael Neuling wrote:
One problem with this is when we construct the instructions, like using
anything from ppc-opcode.h. eg. using PPC_POPCNTB would need to go from:
PPC_POPCNTB(r3,r3)
to:
PPC_POPCNTB(3,3)
Which is less readable IMHO.
Yes, I know. Not much to do about this, but it might still be worth it,
how much time wasted due to mixing up or with ori in asm somewhere ?
One option would be to #define R3 (or _r3) for use in those macros so
we still have something nicer than just "3"... oh well.
Cheers,
Ben.