Re: [PATCH] powerpc: Optimise the 64bit optimised __clear_user

From
Michael Neuling <hidden>
Date
2012-06-07 06:05:04
Reply to
Benjamin Herrenschmidt, 2012-06-06
Benjamin Herrenschmidt [off-list ref] wrote:
On Wed, 2012-06-06 at 18:40 +0200, Segher Boessenkool wrote:
quoted
quoted
+err1;	dcbz	r0,r3
There is no such instruction, you probably meant "dcbz 0,r3"?
This reminds me... what would happen if we changed all our

#define	r0	0
#define	r1	1

etc... to:

#define r0	%r0
#define r1	%r1

?

I'm thinking it might help catch that sort of nasties (and some of them
can be really nasty, such as inverting mfspr/mtspr arguments, or vs ori,
etc... ). I'm sure we'd have a problem with a few macros & inline
constructs but nothing we can't fix..
One problem with this is when we construct the instructions, like using
anything from ppc-opcode.h.  eg. using PPC_POPCNTB would need to go from:
    PPC_POPCNTB(r3,r3) 
to:
    PPC_POPCNTB(3,3) 
Which is less readable IMHO.

Mikey
Thread (38 messages) 38 messages, 12 authors, last reply 2012-06-14
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help