Re: [PATCH v2 4/4] [libata] pata_platform: s/ioport_shift/reg_shift/g
From: Paul Mundt <hidden>
Date: 2007-12-05 00:57:08
Also in:
linux-ide
From: Paul Mundt <hidden>
Date: 2007-12-05 00:57:08
Also in:
linux-ide
On Tue, Dec 04, 2007 at 08:07:45PM +0300, Anton Vorontsov wrote:
This patch renames ioport_shift member of pata_platform_info structure to reg_shift. Users of pata_platform are followed appropriately. Rationale of that change is: shifting applies to the whole memory mapped region, not only to the command block of the ATA registers, despite the fact that shifting is meaningless for ctl register.
It's called ioport_shift because of the fact it shifts an ioport, namely a struct ata_ioport *. We could rename it, but I really don't see the point. If you don't like the choice of name on your platform, add a comment to your platform-specific code noting this particular outrage so it can be grepped for by future generations ;-) Nacked-by: Paul Mundt [off-list ref]