Re: [PATCH v2 1/4] [libata] pata_platform: make probe and remove functions device type neutral
From: Olof Johansson <hidden>
Date: 2007-12-04 20:36:57
Also in:
linux-ide
From: Olof Johansson <hidden>
Date: 2007-12-04 20:36:57
Also in:
linux-ide
On Tue, Dec 04, 2007 at 08:06:25PM +0300, Anton Vorontsov wrote:
Split pata_platform_{probe,remove} into two pieces:
1. pata_platform_{probe,remove} -- platform_device-dependant bits;
2. __ptata_platform_{probe,remove} -- device type neutral bits.
This is done to not duplicate code for the OF-platform driver.
Signed-off-by: Anton Vorontsov <redacted>Acked-by: Olof Johansson <redacted> Tested with both the old pata_platform and new pata_of_platform drivers on PA Semi Electra (see separate post with pata_of_platform cutover patch). -Olof